Metal Torrent Tracker Forum

Полная версия: Deluge 2.0.3 - Error invalid argument
Вы просматриваете yпpощеннyю веpсию форума. Пеpейти к полной веpсии.
Since upgrading to deluge 2.0.3 all the torrents I was seeing on this tracker have gone into an error state. The tracker status says "Error: invalid argument". Since other trackers are doing just fine, I was wondering whether this could be an issue on the tracker or not?
(08-14-2019, 09:26 PM)Twisted- Писал(а): [ -> ]Since upgrading to deluge 2.0.3 all the torrents I was seeing on this tracker have gone into an error state. The tracker status says "Error: invalid argument". Since other trackers are doing just fine, I was wondering whether this could be an issue on the tracker or not?

I haven't had any issues with the tracker but I'm using Deluge 1.3.15.  If this problem persists I would recommend getting an older version of Deluge to see if that will fix the error.  Suggestion going forward I would never upgrade torrent software unless it is absolutely necessary or is a new layout and/or feature that you need or want.  In my experiences upgrading torrent software is never really needed, if may state is faster DL speeds but I have never found this to be true.  Find a good working version and stick with it until they is a compatibility issue ex- windows upgrade.
I used to run 1.3.15 without these kind of problems was well.

Deluge 1.3.15 didn't scale very well, it was getting rather sluggish the more torrents I added to it.

Considering they promised this was something they presumably fixed in 2.0.x I was eager to upgrade.

As far going back, that isn't really an option. Configuration files and the database for deluge have been upgraded and isn't compatible anymore with the old version. Since I don't have a backup and I don't want to re-add all my torrents manually.

For now I'm moving my new torrents into Qbittorrent, but I'd like to merge them again at some point and also start reseeding the 100+ metaltracker torrents I have on there.
You really have to update your torrent software, I'd recommend the latest version of qbittorrent. Why, you may ask. Well, as you might be aware of, most people tend to use utorrent, the commercial software, which quite recently made up a slightly modified version of a protocol, they call it uTP (with the weird u), and as time goes on, more and more people will update their clients, and you'll start seeing less seeders, thus making it slower.
Though it's kind of bad news that some company is imposing their made up protocol, I think it's for the best because it's based on the old ass UTP which is faster than TCP, with the downside of less security regarding the management of missing or corrupted packets, but with today's connections as well as other systems implemented outside of the protocol it's not needed.
(08-14-2019, 09:26 PM)Twisted- Писал(а): [ -> ]Since upgrading to deluge 2.0.3 all the torrents I was seeing on this tracker have gone into an error state. The tracker status says "Error: invalid argument". Since other trackers are doing just fine, I was wondering whether this could be an issue on the tracker or not?

If anyone happens to find this thread and has the same issues: I have managed to resolve my problem by upgrading the python3-libtorrent/rasterbar9/10 version to 1.2.2 by adding a PPA https://launchpad.net/~libtorrent.org from over there.

Now I have a whole bunch of "Address family not supported by protocol" errors, but that doesn't seem to stop it from downloading and seeding.